lopslag hjælp i excel - Amino.dk
på Amino
Bliv gratis medlem på Amino

Nye ekspertblog-indlæg
om  Alt det andet..

Læs flere ekspertindlæg
 

Top karmaliste (30 dage)

De flinkeste Amino’er der hjælper mest med "Generel iværksætterdebat "

 

lopslag hjælp i excel

Side 1 ud af 2 (12 indlæg) 1 2 Næste >
Amino-karma 44
Tilmeldt 10. dec 14
Indlæg ialt: 10


Fra Danskautoshop / danskf...
Skrevet 20-08-2018 kl. 09:18

hej har et regneark, hvor jeg har lidt udfordringer med at få en formel lavet. 
Er der en der har mulighed for at hjælpe mig med at lave sådan en formel, da det ikke er lykkes mig efter utallige forsøg. 

Evt. en der mod betaling vil lave en kode til os?


hvor jeg i price Ark 1 (kolonne L),
vil have den til at hente data i reference (kolonne G) i ark 1,
Søge i reference (kolonne G) i ark 2 efter samme tal,
referere price fra (kolonne L) ark 2,

Så prisen fra kolonne L i ark 2 bliver sat ind i kolonne L i ark 1 
hvis den melder fejl, vil jeg gerne have den til at skrive 0 kolonne S i ark 1.


Ark 1

id_product SystemGroup NameGroup manufacturer id_manufacturer id_bra_tecdoc reference ean13 name quantity minimal_quantity price
67815 Bremsesystem Rep.sæt, bremsekaliper NK 125 127 8819026 5700750078230 NK 8819026 - Rep.sæt, bremsekaliper 0 1 #I/T

Ark 2

id_product SystemGroup NameGroup manufacturer id_manufacturer id_bra_tecdoc reference ean13 name quantity minimal_quantity price
67815 Bremsesystem Rep.sæt, bremsekaliper NK 125 127 8819026 5700750078230 NK 8819026 - Rep.sæt, bremsekaliper 0 1 #I/T
Amino-karma 357
Tilmeldt 20. apr 13
Indlæg ialt: 88

Kpt
Skrevet 20-08-2018 kl. 09:25

Prøv evt at kikker her https://proximo.dk/excel-vlookup/

Amino-karma 44
Tilmeldt 10. dec 14
Indlæg ialt: 10

Børge Møller
Fra Danskautoshop / danskf...
Skrevet 20-08-2018 kl. 09:33

Det faktisk denne jeg har brugt til hjælp, men desværre kan jeg ikke få det til at lykkes trods det.

Amino-karma 924
Fra 7840 Højslev
Tilmeldt 21. okt 08
Indlæg ialt: 255
Amino Plus
Peter Braagaard
Fra Supertekst
Skrevet 20-08-2018 kl. 10:21

Hej Børge

Når du skriver "kode" - så er det vel VBA-kode du tænker på - eller?

Hvis ja - så er du velkommen til at anvende www.supertekst-it.dk / Kontakt

Mvh

Peter Braagaard

Amino-karma 44
Tilmeldt 10. dec 14
Indlæg ialt: 10

Børge Møller
Fra Danskautoshop / danskf...
Skrevet 20-08-2018 kl. 10:28

Det er en formel eller kode lige som denne =LOPSLAG($G2;PRISER!A1:R2767;18;FALSK) 
Har lige sendt dig en besked via kontakt formularen.

Amino-karma 25
Tilmeldt 18. aug 18
Indlæg ialt: 7

PatrickI
Fra PI Værdiansættelse
Skrevet 20-08-2018 kl. 12:37

Hvis jeg har forstået dit problem, så ønsker du at lave en LOPSLAG-formel, hvor du sammenligner 2 værdier automatisk og derved kommer med et sandt/falsk output?

Ud fra den ovenstående formel du har skrevet, mangler du at indarbejde det i en HVIS-formel.

Et udkast til udseendet vil være:
=HVIS(LOPSLAG(x)=LOPSLAG(y);”Sandt;”Falsk”)

Giver dette mening?

Amino-karma 44
Tilmeldt 10. dec 14
Indlæg ialt: 10

Børge Møller
Fra Danskautoshop / danskf...
Skrevet 22-08-2018 kl. 08:55

Nej syntes jeg bestemt ikke giver mening, for hvis jeg læser om Lopslag andre steder, så bliver det næsten altid skrevet på den anden måde som jeg har skrevet. Hvilket undre mig.

Som jeg læser HVIS formlen, så er det kun til at fortælle om det er sandt eller falsk, jeg vil gerne have den til at taste den værdi der står x-antal kolonner til højre for den værdi den fandt, Samt hvis den ikke fandt noget skrive 0 i kolonne S i ark1

Amino-karma 25
Tilmeldt 18. aug 18
Indlæg ialt: 7

PatrickI
Fra PI Værdiansættelse
Skrevet 22-08-2018 kl. 09:04

Du skal også benytte LOPSLAG korrekt, ikke som jeg tidligere skrev med LOPSLAG(x). Det er blot for at vise, hvor funktionen skal være.

LOPSLAG skal benyttes som:
LOPSLAG(Opslagsværdi;Tabel;Kolonne)

Men hvad du ønsker, vil være:
HVIS(LOPSLAG(x)=LOPSLAG(y);LOPSLAG(x);0)

Jeg kan ikke give dig mere korrekte instrukser uden dit regneark.

Amino-karma 924
Fra 7840 Højslev
Tilmeldt 21. okt 08
Indlæg ialt: 255
Amino Plus
Peter Braagaard
Fra Supertekst
Skrevet 22-08-2018 kl. 09:20

Hej Børge

Har sendt resultatet af det ønskede til Henrik i går aftes. Det er en VBA løsning 

mvh

Peter Braagaard

Amino-karma 44
Tilmeldt 10. dec 14
Indlæg ialt: 10

Børge Møller
Fra Danskautoshop / danskf...
Skrevet 22-08-2018 kl. 10:32

i går havde jeg ingen problemer med at åbne den på min computer der hjemme, men både på mobilen og på computeren her på firmaet kan jeg ikke. 
Men umildbart kunne jeg ikke lige se hvad du havde ændret, derfor jeg ville se på det i dag her på arbejdet.

Derfor tænkte jeg at jeg ville se på det i eftermiddag, når jeg havde fri.

Side 1 ud af 2 (12 indlæg) 1 2 Næste >

RSS-feed
 
Besøg vores samarbejdspartnere :